https://github.com/cran/bayestestR
Raw File
Tip revision: 601edcd8d1306ebea478657861c54fa9c69a52f3 authored by Dominique Makowski on 31 May 2021, 05:40 UTC
version 0.10.0
Tip revision: 601edcd
plot.R
#' @export
plot.equivalence_test <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot results from equivalence-test. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}


#' @export
plot.p_direction <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot results from p_direction(). Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}


#' @export
plot.point_estimate <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot point-estimates. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}


#' @export
plot.map_estimate <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot point-estimates. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}


#' @export
plot.rope <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot ROPE. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}


#' @export
plot.bayestestR_hdi <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot HDI. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}


#' @export
plot.bayestestR_eti <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot credible intervals. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}

#' @export
plot.bayestestR_si <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot support intervals. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}

#' @export
plot.bayesfactor_parameters <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot Savage-Dickey Bayes factor. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}

#' @export
plot.bayesfactor_models <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot models' Bayes factors. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}

#' @export
plot.estimate_density <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot densities. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}

#' @export
plot.estimate_density_df <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot densities. Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}

#' @export
plot.p_significance <- function(x, ...) {
  if (!requireNamespace("see", quietly = TRUE)) {
    stop("Package 'see' needed to plot practical significance Please install it by running `install.packages('see')`.")
  }
  NextMethod()
}
back to top