Revision 51ecff3c0b96c8bc9ab0a065871b5aa38bb3393d authored by Mikhail Kolmogorov on 27 July 2018, 01:39:47 UTC, committed by Mikhail Kolmogorov on 27 July 2018, 01:39:47 UTC
1 parent 2300e45
Raw File
ragout.py
#!/usr/bin/env python2.7

#(c) 2013-2014 by Authors
#This file is a part of Ragout program.
#Released under the BSD license (see LICENSE file)

"""
This script does all the necessary preparations
and invokes Ragout
"""

import os
import sys

LIB_DIR = "lib"

#Check Python version
if sys.version_info[:2] != (2, 7):
    print("Error: Ragout requires Python version 2.7 ({0}.{1} detected)."
          .format(sys.version_info[0], sys.version_info[1]))
    sys.exit(-1)

#Setting executable paths
ragout_root = os.path.dirname(os.path.realpath(__file__))
lib_absolute = os.path.join(ragout_root, LIB_DIR)
sys.path.insert(0, lib_absolute)
sys.path.insert(0, ragout_root)
os.environ["PATH"] = lib_absolute + os.pathsep + os.environ["PATH"]

#Ragout entry point
from ragout.main import main
sys.exit(main())
back to top