swh:1:snp:076368cbf342de01274868b2f8742ab4e62222ef
Raw File
Tip revision: 69c9c2e226e29abd4e169d8439b83c6c0aa6aef6 authored by Benjamin Gregoire on 11 November 2022, 08:06:12 UTC
add few lemmas on dfun
Tip revision: 69c9c2e
default.nix
with import <nixpkgs> {};

if !lib.versionAtLeast why3.version "1.4" then
  throw "please update your nixpkgs channel: nix-channel --update"
else
let why3_local =
  if !lib.versionAtLeast why3.version "1.5" then
  why3.overrideAttrs (o: rec {
    version = "1.5.0";
    src = fetchurl {
      url = "https://why3.gitlabpages.inria.fr/releases/${o.pname}-${version}.tar.gz";
      sha256 = "sha256:0qjh49pyqmg3xi09fn4lyzz23i6h18y9sgc8ayscvx3bwr3vcqhr";
    };
  })
  else why3
; in
let why3 = why3_local; in

let merlin = 
    ocamlPackages.merlin.overrideAttrs (o: {
    doCheck = false;
    }); in

  stdenv.mkDerivation {
    name = "easycrypt-1.0";
    src = ./.;
    buildInputs = [ why3 merlin] ++ (with ocamlPackages; [
      ocaml
      findlib
      batteries
      camlp-streams
      dune_2
      dune-build-info
      dune-site
      inifiles
      menhir
      menhirLib
      yojson
      zarith
    ]);
    installFlags = [ "PREFIX=$(out)" ];
  }
back to top