swh:1:snp:510544f7899e7fee487ee146b60cd834a253fd12
Raw File
Tip revision: 189283a215d9d93ed5819f037d38e1f9131acc92 authored by Pierre-Yves Strub on 15 March 2023, 06:59:34 UTC
Move to github docker repository
Tip revision: 189283a
shell.nix
{ withProvers ? true, devDeps ? [] }:

let why3_local =
  why3.overrideAttrs (o : rec {
    version = "1.5.1";
    src = fetchurl {
      url = "https://why3.gitlabpages.inria.fr/releases/${o.pname}-${version}.tar.gz";
      sha256 = "sha256-vNR7WeiSvg+763GcovoZBFDfncekJMeqNegP4fVw06I=";
    };
  });
in
let why3 = why3_local; in

with import <nixpkgs> {};

let provers =
  if withProvers then [
    alt-ergo
    z3
  ] else []; in

pkgs.mkShell {
  buildInputs = devDeps ++ [ git ] ++ (with ocamlPackages; [
    ocaml
    findlib
    batteries
    camlp-streams
    dune_3
    dune-build-info
    dune-site
    inifiles
    menhir
    menhirLib
    merlin
    yojson
    why3
    zarith
  ]) ++ (with python3Packages; [
    pyyaml
  ]);
}
back to top