swh:1:snp:510544f7899e7fee487ee146b60cd834a253fd12
Raw File
Tip revision: 67e47efea6442eef5b7a3bfd5991bd2c56daf360 authored by Adrien Koutsos on 01 March 2023, 11:53:24 UTC
fixed compilation issues after merge.
Tip revision: 67e47ef
shell.nix
{ withProvers ? true, devDeps ? [] }:

with import <nixpkgs> {};

let provers =
  if withProvers then [
    alt-ergo
    z3
  ] else []; in

pkgs.mkShell {
  buildInputs = devDeps ++ [ git ] ++ (with ocamlPackages; [
    ocaml
    findlib
    batteries
    camlp-streams
    dune_3
    dune-build-info
    dune-site
    inifiles
    menhir
    menhirLib
    merlin
    yojson
    why3
    zarith
  ]) ++ (with python3Packages; [
    pyyaml
  ]);
}
back to top